Keyboard only working with shortcuts

Punk

Founding Member
Supermoderator
Messages
197
Hey guys, this is strange...

Since I started my computer this morning, the keyboard has been acting weird. Instead of acting like a keyboard (writes "p" when you press "p"), it opens shortcuts when I press different keys. For example, E opens the file navigator, R the Run command prompt, U Display settings, I the Control Panel, Q and S Search... I have tried rebooting, looking into settings of the keyboard and accessibility but haven't found a fix.

Do you have any idea what's going on? Opening a cold local beer hasn't helped me either, don't know what else to do...
 

Cromewell

Active Member
Administrator
Messages
269
Sounds like your windows key is stuck. It might not actually be stuck, just soft. Give it a few presses and see if it starts to work normally. If it's usb, you might be able to reset the driver by unplugging and replugging it.
 

Punk

Founding Member
Supermoderator
Messages
197
Tried that already, but to no avail...
It's a mechanical keyboard, I removed the cap and tried to clean/press it for a while but it didn't change anything :/
I also started the on-screen keyboard and the windows key was pressed (yellow). I'm not sure if it's default like that or not though, as I unplugged the keyboard and started the on-screen keyboard and it was still yellow (all other keys are black).
 

Punk

Founding Member
Supermoderator
Messages
197
I noticed that when I unplug the keyboard, use the on-screen one and click on the windows button, it becomes black as it's unused. When I plug the keyboard back and press any key, it comes back and shortcuts happen again... I'm guessing the keyboard is the problem, will try to see if there is something not working properly inside. If not, I will try the system restore.
 

Punk

Founding Member
Supermoderator
Messages
197
Just did a system restore to yesterday before an update (only option and it didn't work). I'm out of options here, will probably reinstall...
 

Cromewell

Active Member
Administrator
Messages
269
Do you have another system to try the keyboard on? Maybe the switch in the windows key has failed.
 

Punk

Founding Member
Supermoderator
Messages
197
I could try on my Laptop.

I just removed the switch, shut down the computer, boot, the problem is still happening :/
Restored Windows (without deleting personal files), booted, used the on-screen keyboard to see what key was pressed, none were. Used the keyboard, boom windows key is pressed.

I'm guessing the keyboard electronics is the problem? It's 50€ Allreli K645 mechanical keyboard...

What I don't understand is that after I unplug the keyboard, restart, the windows button is still constantly pressed on the on-screen keyboard... This makes me think of a Windows problem more than a mechanical problem :/

Yeah I'm kind of at lost on this. Thinking about re-starting Windows from fresh (free, just time consuming) and buying a new keyboard ($$$)...

Just found this online, same problem except none of wha( he's done to fix it works for me...
 

johnb35

Active Member
Administrator
Messages
525
Try a cheap keyboard first, borrow one if you have to. Tbh, this sounds more like a windows issue. Did you install any new programs yesterday?
 

Punk

Founding Member
Supermoderator
Messages
197
Yes I'm more leaning towards a Windows problem. I'll see if I can get my hand on a cheap keyboard at work.

This morning, I started the computer without the keyboard plugged in, the windows logo wasn't pressed on the on-screen keyboard yet it still worked as if the windows button was pressed. Keep in mind that yesterday I restored Windows without losing files and that I had plugged the keyboard yesterday night to try it. Also, something I noticed, the keyboard stayed on all night although the computer was off. Normally, it would turn off with the computer...
 

johnb35

Active Member
Administrator
Messages
525
Also, something I noticed, the keyboard stayed on all night although the computer was off. Normally, it would turn off with the computer...
That means your USB ports are still getting power while system is off. My mouse does the same thing but not my keyboard. You may have to wipe the drive and install fresh.
 

Punk

Founding Member
Supermoderator
Messages
197
Ok I'm guessing this is the keyboard now, first screens of the new installs, they ask you to enter your wifi password. It worked as if the Windows key was pressed...

I'll find another one tomorrow and end this installation to see if it works.
 

Cromewell

Active Member
Administrator
Messages
269
That means your USB ports are still getting power while system is off. My mouse does the same thing but not my keyboard.
One is probably a charging port while the other isn't. It's pretty normal to see on most mobos.


You said you removed the switch, did you mean they key cover, or the entire switch? The entire switch was likely soldered down.
 
Last edited:

Punk

Founding Member
Supermoderator
Messages
197
One is probably a charging port while the other isn't. It's pretty normal to see on most mobos.


You said you removed the switch, did you mean they key cover, or the entire switch? The entire switch was likely soldered down.
I removed the entire switch, it's a cheap keyboard, probably broke it. But it worked when I put it back without soldering.

Something interesting is that when I press FN + del, it enters a macro mode. And when I'm in that mode the windows button is lit while all the others are turned off... This makes me think that there is a problem on the keyboard and on Windows...
 

Punk

Founding Member
Supermoderator
Messages
197
Ok I think it's time for an update...

After the fail of reinstalling Windows not fixing the issue, I decided to unplugg all my other drives and just work with SSD where I wanted Windows to be on. I deleted all partitions and recreated a new one with the whole space of the SSD, re-installed Windows. Everything seems to be working fine now, I plugged all my other drives and it is still working fine.

I have no idea where this issue is coming from BUT, my instinct is telling me that Windows was the problem as the keyboard is working fine now. For references, I had all the issue mentionned in the post I linked earlier, like clicking on a channel of Discord making it re-connect. All these issues are now gone. Let's hope it stays that way...
 
Top